msqsw

wx_15906661205815.png

spine.log


从3.8.95版本退回3.5.51之后 无法打开设置选项 也没法重新改版本了
You do not have the required permissions to view the files attached to this post.
User avatar
msqsw
  • Posts: 15

Erika

在较新版本的Spine中将语言设置为中文,然后回到较旧版本的Spine时,会发生这种情况。 如果重新启动Spine,错误可能会消失。 如果没有,您可以删除prefs.json文件,然后启动Spine:
Windows:<用户主文件夹> \ Spine \ prefs.json
Mac:<用户主文件夹> / Library / Application Support / Spine / prefs.json
Linux:<用户主文件夹> /。spine / prefs.json

这是旧版本无法读取更新的prefs.json文件的错误。 由于我们不对旧版本进行更新,因此很遗憾,我们无法对其进行修复。 但是,我们改进了在v3.9 +中的工作方式。

This happens when setting the language to Chinese in a newer version of Spine, then going back to an older version of Spine. If you restart Spine the error may go away. If not, you can delete your prefs.json file, then start Spine:
Windows: <user home folder>\Spine\prefs.json
Mac: <user home folder>/Library/Application Support/Spine/prefs.json
Linux: <user home folder>/.spine/prefs.json

It is a bug with older versions not being able to read the newer prefs.json file. Since we don't do updates to older versions, unfortunately we aren't able to fix it. However, we've improved how this works in v3.9+.
User avatar
Erika

Erikari
  • Posts: 2548

msqsw

thanks
User avatar
msqsw
  • Posts: 15


Return to 中国Spine用户